Stripe (our payment processor) is experiencing some difficulties

Incident Report for Sauce Online Ordering

Resolved

Stripe is back to normal.
Posted May 11, 2020 - 13:17 EDT

Update

Additional information can be found on Stripe's status page here: https://status.stripe.com/
Posted May 11, 2020 - 12:39 EDT

Update

We are continuing to investigate this issue.
Posted May 11, 2020 - 12:38 EDT

Investigating

Stripe reports that it is experiencing difficulties, as such our online ordering system might not be able to process some of the payments.
We are actively monitoring it.
Posted May 11, 2020 - 12:38 EDT
This incident affected: Online Ordering.